Bananian Linux

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000055Bananian Linux[All Projects] Kernelpublic2014-10-11 12:042016-03-25 09:19
ReporterMatthias 
Assigned ToNico 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusresolvedResolutionfixed 
Product Version14.09 
Target Version16.04Fixed in Version16.04 
Summary0000055: Division by zero in kernel. (3.4.90+)
DescriptionThere are divisions by zero if my banana pi is a little bit busy. (For example transfers with rsync)

cat /proc/version
Linux version 3.4.90+ (root@nico-desktop) (gcc version 4.8.2 (Ubuntu/Linaro 4.8.2-16ubuntu4) ) #1 SMP PREEMPT Fri Sep 12 18:13:45 CEST 2014
Additional Informationdmesg output:

[Sa Okt 11 11:49:03 2014] Division by zero in kernel.
[Sa Okt 11 11:49:03 2014] [<c0015018>] (unwind_backtrace+0x0/0x134) from [<c02c7658>] (Ldiv0+0x8/0x10)
[Sa Okt 11 11:49:03 2014] [<c02c7658>] (Ldiv0+0x8/0x10) from [<c00e7944>] (vmpressure_work_fn+0x6c/0x180)
[Sa Okt 11 11:49:03 2014] [<c00e7944>] (vmpressure_work_fn+0x6c/0x180) from [<c004c74c>] (process_one_work+0x12c/0x3b0)
[Sa Okt 11 11:49:03 2014] [<c004c74c>] (process_one_work+0x12c/0x3b0) from [<c004cd24>] (worker_thread+0x158/0x394)
[Sa Okt 11 11:49:03 2014] [<c004cd24>] (worker_thread+0x158/0x394) from [<c0051300>] (kthread+0x90/0x94)
[Sa Okt 11 11:49:03 2014] [<c0051300>] (kthread+0x90/0x94) from [<c000f438>] (kernel_thread_exit+0x0/0x8)
[Sa Okt 11 11:49:03 2014] Division by zero in kernel.
[Sa Okt 11 11:49:03 2014] [<c0015018>] (unwind_backtrace+0x0/0x134) from [<c02c7658>] (Ldiv0+0x8/0x10)
[Sa Okt 11 11:49:03 2014] [<c02c7658>] (Ldiv0+0x8/0x10) from [<c00e7958>] (vmpressure_work_fn+0x80/0x180)
[Sa Okt 11 11:49:03 2014] [<c00e7958>] (vmpressure_work_fn+0x80/0x180) from [<c004c74c>] (process_one_work+0x12c/0x3b0)
[Sa Okt 11 11:49:03 2014] [<c004c74c>] (process_one_work+0x12c/0x3b0) from [<c004cd24>] (worker_thread+0x158/0x394)
[Sa Okt 11 11:49:03 2014] [<c004cd24>] (worker_thread+0x158/0x394) from [<c0051300>] (kthread+0x90/0x94)
[Sa Okt 11 11:49:03 2014] [<c0051300>] (kthread+0x90/0x94) from [<c000f438>] (kernel_thread_exit+0x0/0x8)
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000058)
Nico (manager)
2014-10-19 12:38

Can you reproduce the errors with Raspbian and/or Lubuntu?

I can't reproduce the error on my system.
(0000060)
Mayk (reporter)
2014-10-21 18:39

Hello Matthias and Nico,

I confirm this bug is in current raspian:

[23635.931454] Division by zero in kernel.
[23635.943126] [<c0015018>] (unwind_backtrace+0x0/0x134) from [<c02c7658>] (Ldiv0+0x8/0x10)
[23635.951197] [<c02c7658>] (Ldiv0+0x8/0x10) from [<c00e7944>] (vmpressure_work_fn+0x6c/0x180)
[23635.959973] [<c00e7944>] (vmpressure_work_fn+0x6c/0x180) from [<c004c74c>] (process_one_work+0x12c/0x3b0)
[23635.967975] [<c004c74c>] (process_one_work+0x12c/0x3b0) from [<c004cd24>] (worker_thread+0x158/0x394)
[23635.974955] [<c004cd24>] (worker_thread+0x158/0x394) from [<c0051300>] (kthread+0x90/0x94)
[23635.982761] [<c0051300>] (kthread+0x90/0x94) from [<c000f438>] (kernel_thread_exit+0x0/0x8)
[23635.985780] Division by zero in kernel.
[23635.992973] [<c0015018>] (unwind_backtrace+0x0/0x134) from [<c02c7658>] (Ldiv0+0x8/0x10)
[23636.000425] [<c02c7658>] (Ldiv0+0x8/0x10) from [<c00e7958>] (vmpressure_work_fn+0x80/0x180)
[23636.009082] [<c00e7958>] (vmpressure_work_fn+0x80/0x180) from [<c004c74c>] (process_one_work+0x12c/0x3b0)
[23636.017467] [<c004c74c>] (process_one_work+0x12c/0x3b0) from [<c004cd24>] (worker_thread+0x158/0x394)
[23636.024636] [<c004cd24>] (worker_thread+0x158/0x394) from [<c0051300>] (kthread+0x90/0x94)
[23636.032114] [<c0051300>] (kthread+0x90/0x94) from [<c000f438>] (kernel_thread_exit+0x0/0x8)

It happened under medium to heavy load while binary-comparing two massive directory trees plus occasional mounting/unmounting of an nfs share. I'm not sure what triggered it, the filesystem I was running the compare from is btrfs,
(0000089)
Nico (manager)
2014-11-20 09:00

Can you please test with the upcoming 14.11 release?
(0000110)
Matthias (reporter)
2014-12-17 22:07

Hello guys!

I can still confirm this bug in the release 14.11. This time I was copying files with rsync from A to B.

A = DD-Image (ext4) encrypted with dm-crypt on a real ext4 partition (extended USB drive)
B = DD-Image (btrfs) encrypted with dm-crypt on a real ext4 partition (extended USB drive)

cat /proc/version
Linux version 3.4.104+ (root@nico-desktop) (gcc version 4.8.2 (Ubuntu/Linaro 4.8.2-16ubuntu4) ) #3 SMP PREEMPT Wed Nov 19 08:28:34 CET 2014

cat /etc/bananian_version 
141101


dmesg output:

[Mi Dez 17 18:08:42 2014] Division by zero in kernel.
[Mi Dez 17 18:08:42 2014] [<c0015058>] (unwind_backtrace+0x0/0x134) from [<c02c8c18>] (Ldiv0+0x8/0x10)
[Mi Dez 17 18:08:42 2014] [<c02c8c18>] (Ldiv0+0x8/0x10) from [<c00e7fe0>] (vmpressure_work_fn+0x6c/0x180)
[Mi Dez 17 18:08:42 2014] [<c00e7fe0>] (vmpressure_work_fn+0x6c/0x180) from [<c004c7d4>] (process_one_work+0x12c/0x3b0)
[Mi Dez 17 18:08:42 2014] [<c004c7d4>] (process_one_work+0x12c/0x3b0) from [<c004cdac>] (worker_thread+0x158/0x394)
[Mi Dez 17 18:08:42 2014] [<c004cdac>] (worker_thread+0x158/0x394) from [<c0051388>] (kthread+0x90/0x94)
[Mi Dez 17 18:08:42 2014] [<c0051388>] (kthread+0x90/0x94) from [<c000f478>] (kernel_thread_exit+0x0/0x8)
[Mi Dez 17 18:08:42 2014] Division by zero in kernel.
[Mi Dez 17 18:08:42 2014] [<c0015058>] (unwind_backtrace+0x0/0x134) from [<c02c8c18>] (Ldiv0+0x8/0x10)
[Mi Dez 17 18:08:42 2014] [<c02c8c18>] (Ldiv0+0x8/0x10) from [<c00e7ff4>] (vmpressure_work_fn+0x80/0x180)
[Mi Dez 17 18:08:42 2014] [<c00e7ff4>] (vmpressure_work_fn+0x80/0x180) from [<c004c7d4>] (process_one_work+0x12c/0x3b0)
[Mi Dez 17 18:08:42 2014] [<c004c7d4>] (process_one_work+0x12c/0x3b0) from [<c004cdac>] (worker_thread+0x158/0x394)
[Mi Dez 17 18:08:42 2014] [<c004cdac>] (worker_thread+0x158/0x394) from [<c0051388>] (kthread+0x90/0x94)
[Mi Dez 17 18:08:42 2014] [<c0051388>] (kthread+0x90/0x94) from [<c000f478>] (kernel_thread_exit+0x0/0x8)
(0000121)
Nico (manager)
2015-01-02 11:40

This has to be fixed upstream. I am not a kernel developer, sorry.
(0000243)
Matthias (reporter)
2015-05-04 12:09

Hello!

This bug is still annoying me. Where can I report it? Is it really a problem of the vanilla kernel (kernel.org)?


cat /proc/version
Linux version 3.4.104-bananian (root@bananapi) (gcc version 4.6.3 (Debian 4.6.3-14) ) #1 SMP PREEMPT Mon Apr 6 18:25:40 UTC 2015


cat /etc/bananian_version
150401


dmesg output:
[Sa Mai  2 22:58:13 2015] Division by zero in kernel.
[Sa Mai  2 22:58:13 2015] [<c0014e78>] (unwind_backtrace+0x0/0x138) from [<c02ccb58>] (Ldiv0+0x8/0x10)
[Sa Mai  2 22:58:13 2015] [<c02ccb58>] (Ldiv0+0x8/0x10) from [<c00e4c50>] (vmpressure_work_fn+0x60/0x174)
[Sa Mai  2 22:58:13 2015] [<c00e4c50>] (vmpressure_work_fn+0x60/0x174) from [<c004b034>] (process_one_work+0x118/0x388)
[Sa Mai  2 22:58:13 2015] [<c004b034>] (process_one_work+0x118/0x388) from [<c004b648>] (worker_thread+0x16c/0x36c)
[Sa Mai  2 22:58:13 2015] [<c004b648>] (worker_thread+0x16c/0x36c) from [<c004fc34>] (kthread+0x84/0x90)
[Sa Mai  2 22:58:13 2015] [<c004fc34>] (kthread+0x84/0x90) from [<c000f4dc>] (kernel_thread_exit+0x0/0x8)
[Sa Mai  2 22:58:13 2015] Division by zero in kernel.
[Sa Mai  2 22:58:13 2015] [<c0014e78>] (unwind_backtrace+0x0/0x138) from [<c02ccb58>] (Ldiv0+0x8/0x10)
[Sa Mai  2 22:58:13 2015] [<c02ccb58>] (Ldiv0+0x8/0x10) from [<c00e4c64>] (vmpressure_work_fn+0x74/0x174)
[Sa Mai  2 22:58:13 2015] [<c00e4c64>] (vmpressure_work_fn+0x74/0x174) from [<c004b034>] (process_one_work+0x118/0x388)
[Sa Mai  2 22:58:13 2015] [<c004b034>] (process_one_work+0x118/0x388) from [<c004b648>] (worker_thread+0x16c/0x36c)
[Sa Mai  2 22:58:13 2015] [<c004b648>] (worker_thread+0x16c/0x36c) from [<c004fc34>] (kthread+0x84/0x90)
[Sa Mai  2 22:58:13 2015] [<c004fc34>] (kthread+0x84/0x90) from [<c000f4dc>] (kernel_thread_exit+0x0/0x8)
[Mo Mai  4 03:04:55 2015] Division by zero in kernel.
[Mo Mai  4 03:04:55 2015] [<c0014e78>] (unwind_backtrace+0x0/0x138) from [<c02ccb58>] (Ldiv0+0x8/0x10)
[Mo Mai  4 03:04:55 2015] [<c02ccb58>] (Ldiv0+0x8/0x10) from [<c00e4c50>] (vmpressure_work_fn+0x60/0x174)
[Mo Mai  4 03:04:55 2015] [<c00e4c50>] (vmpressure_work_fn+0x60/0x174) from [<c004b034>] (process_one_work+0x118/0x388)
[Mo Mai  4 03:04:55 2015] [<c004b034>] (process_one_work+0x118/0x388) from [<c004b648>] (worker_thread+0x16c/0x36c)
[Mo Mai  4 03:04:55 2015] [<c004b648>] (worker_thread+0x16c/0x36c) from [<c004fc34>] (kthread+0x84/0x90)
[Mo Mai  4 03:04:55 2015] [<c004fc34>] (kthread+0x84/0x90) from [<c000f4dc>] (kernel_thread_exit+0x0/0x8)
[Mo Mai  4 03:04:55 2015] Division by zero in kernel.
[Mo Mai  4 03:04:55 2015] [<c0014e78>] (unwind_backtrace+0x0/0x138) from [<c02ccb58>] (Ldiv0+0x8/0x10)
[Mo Mai  4 03:04:55 2015] [<c02ccb58>] (Ldiv0+0x8/0x10) from [<c00e4c64>] (vmpressure_work_fn+0x74/0x174)
[Mo Mai  4 03:04:55 2015] [<c00e4c64>] (vmpressure_work_fn+0x74/0x174) from [<c004b034>] (process_one_work+0x118/0x388)
[Mo Mai  4 03:04:55 2015] [<c004b034>] (process_one_work+0x118/0x388) from [<c004b648>] (worker_thread+0x16c/0x36c)
[Mo Mai  4 03:04:55 2015] [<c004b648>] (worker_thread+0x16c/0x36c) from [<c004fc34>] (kthread+0x84/0x90)
[Mo Mai  4 03:04:55 2015] [<c004fc34>] (kthread+0x84/0x90) from [<c000f4dc>] (kernel_thread_exit+0x0/0x8)
(0000244)
Nico (manager)
2015-05-05 11:59

Raspbian seems to have the same problem so I would start testing to reproduce the problem with the mainline kernel 3.4.x from kernel.org

If there is a problem too, report it to the mainline kernel, otherwise it looks like a sunxi problem and you have to report it to linux-sunxi.org
(0000256)
Nico (manager)
2015-07-12 20:42

closed again because we can't fix it.
(0000345)
Nico (manager)
2016-03-25 09:19

https://github.com/Bananian/linux-bananapi/commit/4ed9b51fe95e00c882ba10659b1d828fee0f2ba5 [^]
https://github.com/Bananian/linux-bananapi/commit/4f1825f7c3753ccb7bde67967051b1f3bd15f71f [^]

- Issue History
Date Modified Username Field Change
2014-10-11 12:04 Matthias New Issue
2014-10-19 12:37 Nico Assigned To => Nico
2014-10-19 12:37 Nico Status new => assigned
2014-10-19 12:38 Nico Note Added: 0000058
2014-10-21 18:39 Mayk Note Added: 0000060
2014-11-20 09:00 Nico Note Added: 0000089
2014-12-17 22:07 Matthias Note Added: 0000110
2015-01-02 11:40 Nico Note Added: 0000121
2015-01-02 11:40 Nico Status assigned => resolved
2015-01-02 11:40 Nico Resolution open => not fixable
2015-05-04 12:09 Matthias Note Added: 0000243
2015-05-04 12:09 Matthias Status resolved => feedback
2015-05-04 12:09 Matthias Resolution not fixable => reopened
2015-05-05 11:59 Nico Note Added: 0000244
2015-07-12 20:42 Nico Note Added: 0000256
2015-07-12 20:42 Nico Status feedback => resolved
2015-07-12 20:42 Nico Resolution reopened => not fixable
2016-03-25 09:19 Nico Status resolved => feedback
2016-03-25 09:19 Nico Resolution not fixable => reopened
2016-03-25 09:19 Nico Note Added: 0000345
2016-03-25 09:19 Nico Status feedback => resolved
2016-03-25 09:19 Nico Fixed in Version => 16.04
2016-03-25 09:19 Nico Resolution reopened => fixed
2016-03-25 09:19 Nico Target Version => 16.04


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker