Bananian Linux

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000188Bananian Linux[All Projects] Networkpublic2016-02-12 08:392016-06-20 08:38
Reporterbanedos 
Assigned ToNico 
PriorityhighSeveritymajorReproducibilityalways
StatusresolvedResolutionno change required 
Product Version15.08 
Target VersionFixed in Version 
Summary0000188: Can't connect through ssh
DescriptionMy laptop: win7, auto ip in ethernet Lan
Banana pi.
Tried with raspbian for banana pi - works fine.
Tried with bananian(1508) - got trouble(also 1504 doesn't work(edited uEnv.txt)):
Ping bananapi - node unavailable
Ssh(via putty) - connection refused
Steps To ReproduceWrite bananian1508 image to SD card
Open sd card in explorer on laptop(laptop ethernet ip - ip=169.254.144.166
Edit boot.cmd:(add ip=169.254.144.14)
edit line 9: setenv bootargs console=ttyS0,115200 console=tty0 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline ip=169.254.144.14 rootwait
edit line 17 setenv bootargs console=ttyS0,115200 console=tty0 console=tty1 sunxi_g2d_mem_reserve=0 sunxi_ve_mem_reserve=0 hdmi.audio=EDID:0 disp.screen0_output_mode=EDID:1680x1050p60 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline ip=169.254.144.14 rootwait

Connect bananapi to laptop via ethernet cable
Insert SdCard into bananapi
PowerOn bananapi

TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000324)
Nico (manager)
2016-02-19 21:08

Please verify when using DHCP.

Your Putty version?
(0000325)
banedos (reporter)
2016-02-21 18:45

Putty version: 0.66

Bananian 1508 also doesn't work with DHCP router :(


Finally it works with bananian 1504 with DHCP router and win7 laptop. (I edited not only uEnv.txt, but also uEnv.txt.video-acc-off and uEnv.txt.video-acc-on)
(0000338)
Nico (manager)
2016-03-20 22:06

we cannot reproduce the issue. Neither with 15.08 nor with 15.04.

DHCP works fine and SSH also.
(0000379)
banedos (reporter)
2016-05-08 03:29

I found this in TTL log:
"Warning - bad CRC, using default environment"
So does it mean that uEnv configs doesn't work?

Also I still can't get it to work.
How you modified uEnv.txt or loader script?
(0000380)
Nico (manager)
2016-05-08 10:46

See http://www.denx.de/wiki/view/DULG/WarningBadCRCUsingDefaultEnvironment [^]

Please connect a display and verify:
- you have a valid ip address
- sshd is running and listening on port 22
- ssh host keys are generated (check for /etc/ssh/ssh_host_*)
- try verbose mode (ssh -v ip, or check putty logs when using windows
- try ssh localhost and ssh ip on Bananian

Please set your ip adress using the Debian way (/etc/network/interfaces) and it will work.
Using boot.cmd/uEnv.txt for this is not tested at all in Bananian. (btw: have you recompiled boot.src after changing boot.cmd?)

I will close this ticket again.
(0000385)
banedos (reporter)
2016-06-20 04:18

For all other users - this is trouble with SD card. Just change it and everything will be okay.

- Issue History
Date Modified Username Field Change
2016-02-12 08:39 banedos New Issue
2016-02-19 21:08 Nico Note Added: 0000324
2016-02-19 21:08 Nico Assigned To => Nico
2016-02-19 21:08 Nico Status new => assigned
2016-02-21 18:45 banedos Note Added: 0000325
2016-03-20 22:06 Nico Note Added: 0000338
2016-03-20 22:06 Nico Status assigned => resolved
2016-03-20 22:06 Nico Resolution open => unable to reproduce
2016-05-08 03:29 banedos Note Added: 0000379
2016-05-08 03:29 banedos Status resolved => feedback
2016-05-08 03:29 banedos Resolution unable to reproduce => reopened
2016-05-08 10:46 Nico Note Added: 0000380
2016-05-08 10:47 Nico Status feedback => resolved
2016-05-08 10:47 Nico Resolution reopened => unable to reproduce
2016-06-20 04:18 banedos Note Added: 0000385
2016-06-20 04:18 banedos Status resolved => feedback
2016-06-20 04:18 banedos Resolution unable to reproduce => reopened
2016-06-20 08:38 Nico Status feedback => resolved
2016-06-20 08:38 Nico Resolution reopened => no change required


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker